MyForexVPS - Our website and billing system is currently down – Incident details

Our website and billing system is currently down

Resolved
Major outage
Started almost 2 years agoLasted about 8 hours

Affected

Website

Major outage from 9:00 AM to 5:02 PM

Billing

Major outage from 9:00 AM to 5:02 PM

Updates
  • Resolved
    Resolved

    The incident was resolved!

    No data-loss.

  • Monitoring
    Monitoring

    We have recovered the functionality of the billing, it is under active testing at the moment. we should be able to release to the users very soon!

    Thank you for your understanding! We do apologize for the inconvenience caused!

  • Update
    Update

    Our website and billing systems are down
    We are continuing to work on a fix for this incident.

  • Identified
    Identified

    Our website functionality is restored, however, it is not possible to place new orders and billing is still not working yet.